收发Hotmail/MSN邮件

Foxmail收发Hotmail/MSN邮件

    Foxmail对Hotmail和MSN邮箱提供了全面的支持， 使用Foxmail，您可以很方便地对Hotmail/MSN邮箱进行邮件的接收和发送。Foxmail收发Hotmail/MSN邮件是通过结合其自带的小工具Foxmail-Hotmail Proxy实现的。每当连接Hotmail/MSN邮箱的时候，Foxmail会自动启动Foxmail-Hotmail Proxy，邮件收发过程与收发普通的POP3邮箱帐户没有很大区别。

    如果希望了解更多关于Foxmail与Foxmail-Hotmail Proxy之间是如何协同工作，实现收发Hotmail/MSN邮件功能的，请参考：

收发Hotmail/MSN邮件实现原理

    为了更好地使用Hotmail/MSN邮箱进行邮件收发，请参考以下设置方法：

帐户设置
多机共用一个Foxmail-Hotmail Proxy

    运行Foxmail程序组下的Foxmail-Hotmail Proxy 程序，然后用鼠标双击系统托盘的Foxmail-Hotmail Proxy图标，点击程序窗口“服务”菜单的“选项”，可进行以下设置：


收发Hotmail/MSN邮件实现原理

    客户端软件（如：Foxmail、Outlook Express等）收发电子邮件，一般是遵循POP3和SMTP协议实现的，电子邮件服务器系统通常都提供POP3和SMTP邮件服务器。然而，微软的Hotmail和MSN邮件系统没有提供POP3和SMTP邮件服务器，而是提供了一个特殊的 HTTP邮件服务器。

    为了实现收发Hotmail/MSN邮件的功能，Foxmail增加了一个小工具Foxmail-Hotmail Proxy。 Foxmail-Hotmail Proxy工作在Foxmail客户端软件与 HTTP邮件服务器之间，起着桥梁作用。它们之间的关系如下图所示：

    接收邮件时，首先，Foxmail把Foxmail-Hotmail Proxy当作一个POP3邮件服务器，并向它发送POP3邮件接收请求。Foxmail-Hotmail Proxy接收到相关指令后，就开始向 HTTP邮件服务器发送收取邮件的HTTP指令，并提供来自Foxmail的邮箱帐号和密码信息。最后，HTTP邮件服务器返回邮件信息，Foxmail-Hotmail Proxy把邮件信息传递给Foxmail，从而完成邮件的接收。

    发送邮件时，Foxmail把Foxmail-Hotmail Proxy当作一个SMTP邮件服务器，并向它发送邮件发送请求。Foxmail-Hotmail Proxy接收到相关指令后，就开始向 HTTP邮件服务器发出发送邮件的HTTP指令，并提供来自Foxmail的邮箱帐号和密码作为验证信息。最后，Foxmail-Hotmail Proxy把来自Foxmail的邮件数据传输到 HTTP邮件服务器，完成邮件发送过程。

    从以上介绍可以看到，Foxmail只是把Foxmail-Hotmail Proxy当作一个具有POP3和SMTP服务的邮件服务，像收发普通邮箱的邮件一样，对Foxmail-Hotmail Proxy执行邮件收发操作，然后再由Foxmail-Hotmail Proxy真正实现对 HTTP邮件服务器的邮件收发。因此，任何一款支持POP3/SMTP协议的电子邮件客户端软件，都可以通过Foxmail-Hotmail Proxy实现收发Hotmail邮件的功能。


帐户设置

    在Foxmail中设置用于Hotmail/MSN邮箱的帐号信息，有以下两种设置方式：


建立Hotmail/MSN帐户

    Foxmail中建立新帐户的详细说明请参考Foxmail帮助的“初次使用指南”。

    在新建帐户向导中，如果填写的邮件地址是Hotmail或者MSN的邮箱地址（如：tiger@hotmail.com或者tiger@msn.com），那么，在“指定邮件服务器”一步会自动选中向导对话框中的“Hotmail/MSN邮件帐户”单选框，同时“POP3服务器”和“SMTP服务器”栏 内自动填写“localhost”。

    如果Foxmail-Hotmail Proxy在本机器上运行，则“POP3服务器”和“SMTP服务器”栏不必修改，如果Foxmail-Hotmail Proxy运行在网络中的某一机器上，设置方法请参考多机共用一个Foxmail-Hotmail Proxy。

    在“POP3邮箱帐号”一栏请填写完整的Hotmail或者MSN邮件地址。


建立Hotmail/MSN连接

    如果不是给Hotmail/MSN邮箱建立独立的帐户，而只是在已有帐户下建立一个用于Hotmail/MSN邮箱的连接，请按以下方法设置：

    在Foxmail中选中一个帐户，通过菜单的“帐户”|“属性”打开帐户属性对话框，选择“其他POP3”，点击“新建”按钮，新建一个POP3连接。

    在弹出对话框的“POP3服务器”一栏，如果Foxmail-Hotmail Proxy在本机器上运行，则应该填写“localhost”，如果Foxmail-Hotmail Proxy运行在网络中的某一机器上，设置方法请参考多机共用一个Foxmail-Hotmail Proxy。

    在“POP3邮箱帐号”一栏请填写完整的Hotmail或者MSN邮件地址。

    注意：如果Foxmail-Hotmail Proxy在本机器上运行，务必选中对话框中的“自动启动Foxmail-Hotmail Proxy”复选框，如果Foxmail-Hotmail Proxy没有启动，收 发Hotmail/MSN邮件就会失败。


端口设置

    如果当前使用的端口已经被其他软件占用了，Foxmail-Hotmail Proxy程序会弹出提示“端口号被其他程序占用”信息框，提醒用户修改端口号。

    通过Foxmail-Hotmail Proxy菜单的“服务”|“设置”打开设置对话框，在“端口”一页显示的是当前使用的端口号。重新设置端口号，建议使用256到65536之间的一个数字。同时需要在Foxmail的Hotmail帐户属性对话框中，选择“邮件服务器”，点击“高级”按钮，在“POP3服务器端口”一栏填写相同的端口号。


其他设置

服务器设置

    在设置对话框的“服务器”页，“HTTP邮件服务器”栏内填写的分别是Hotmail和MSN邮箱的邮件服务器地址，用户不必修改。

    在设置对话框的“服务器”页，选中“使用代理服务器”复选框，并填写正确的代理服务器名和端口号，即可通过代理服务器收发邮件。

其他设置

    在设置对话框的“其他”页，有两个复选项设置：“不收取已读邮件”，表示如果邮件已经在Hotmail邮箱中阅读过，则不收取；“系统启动时自动运行”，表示启动Windows系统时自动运行Foxmail-Hotmail Proxy程序。

      另外，接收Hotmail/MSN邮件，需要经过多步验证检查，连接的时间需要长一些。如果接收时出现“网络操作超时”错误信息，而Foxmail-Hotmail Proxy窗口状态信息显示正常，则应该适当延长Foxmail中网络超时的限制时间。例如，通过Foxmail菜单的“选项”|“系统设置”选择“网络”选项页，把“网络超时”设为 180 秒。


共享使用Hotmail Proxy程序

多机共用一个Foxmail-Hotmail Proxy

    除了在各台计算机上独立运行Foxmail-Hotmail Proxy联合Foxmail收发Hotmail/MSN邮件以外，还可以让Foxmail-Hotmail Proxy运行在网络中的一台机器上， 其他计算机共同使用这个Foxmail-Hotmail Proxy收发Hotmail/MSN邮件。

    采用这种方式，在Foxmail中Hotmail/MSN帐号信息对话框的“POP3服务器”一栏需要填写Foxmail-Hotmail Proxy所在机器的计算机名或者IP地址，并且保证Foxmail-Hotmail Proxy一直在运行着。

    采用这种方式，就不必在每台机器上运行Foxmail-Hotmail Proxy都可以收发Hotmail/MSN的邮件了，因此，可以不选择Hotmail/MSN帐号信息对话框中的“自动启动Foxmail-Hotmail Proxy”。